Security Updates May Restrict Access to TALLEOnline Banking for Outdated Browsers

On October 14th, 2014, Google engineers disclosed a vulnerability in an older encryption protocol called SSLv3.

What does this mean? It means that users of older web browsers that use this 'protocol' exclusively, like Internet Explorer 6, may be exposed to "man-in-the-middle" attacks that could compromise certain information. Although this is usually isolated to older web browsers, some more recent browser versions may also use this setting.

In order to protect your account, TLFCU has disabled support for SSL v3 on www.TLFCU.org. This action may result in some members who are using old web browsers being unable to connect to TALLEOnline Banking.

If you are unable to access TALLEOnline Banking because of this issue, you should be notified on your screen. You can also click here to determine if this is your issue.

To access TALLEOnline Banking, you will need to be using an updated web browser, like one of those listed below:

Should you have any questions, please contact us!